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Introduction to Simulate ONTAP

Simulate ONTAP is a simulator for running Data ONTAP software. It enables you to test the features
of Data ONTAP 7-Mode or clustered Data ONTAP without having to buy new hardware or disturb
your production environment.

Simulate ONTAP is a VMware virtual machine that runs in a hypervisor. You can run Simulate
ONTAP on either a Windows or a Mac system.

Supported VMware applications
You can install Simulate ONTAP only on certain VMware® applications.

You need to install one of the following VMware applications on the host system to use Simulate
ONTAP:

• VMware Workstation
• VMware Player
• VMware vSphere
• VMware Fusion

Limitations and unsupported features
Simulate ONTAP supports most Data ONTAP functionality and the majority of its features.
However, Simulate ONTAP has some functional limitations and does not support some Data
ONTAP features because of the virtualization architecture.

Simulate ONTAP has the following limitations:

• Non-Volatile RAM (NVRAM) is simulated and is not persistent.
Data loss might occur after power cycles. You must shut down the simulator properly to avoid
data loss.

• You can have a maximum of four simulated disk shelves with 14 disk drives per shelf, for a total
of 56 drives per simulator.

• Each simulated drive is limited to 9 GB.

Note: The simulator image comes pre-configured with 28 1 GB disks; 14 each on simulated
disk shelves 0 and 1. Simulated disk shelves 2 and 3 are not populated. You can configure up
to a maximum of 220 GB total space for each Simulate ONTAP node.

• You can create 64-bit aggregates, but they are limited to a maximum of 9 GB per simulated disk
drive.

• Simulate ONTAP is not suitable for applications that require high performance or heavy I/O.
• No more than two instances of the simulator can be booted simultaneously.
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Simulate ONTAP does not support the following features:

• High Availability (CFO/SFO)
• Fibre channel and SAN connectivity
• RLM (Remote LAN Module)
• CFE, BIOS, shelf FW, and so on
• Multipathing

Downloading Simulate ONTAP software
The Simulate ONTAP software is a set of VMware files that have been compressed in a zip file. You
need to download the appropriate software and license files from the NetApp Support Site.

About this task

A separate zip file is available depending on whether you want to create a Data ONTAP 7-Mode or
clustered Data ONTAP simulator. There are also separate zip files depending on whether you plan to
run the simulator on VMware ESX, or on the other supported VMware desktop applications.

Steps

1. Log in to the NetApp Support Site at support.netapp.com.

2. Type your user name and password and click Login.

3. In the Downloads section, select Utility ToolChest.

The Utility ToolChest page is displayed.

4. Scroll down the list of tools and select Simulate ONTAP.

The Simulate ONTAP page is displayed.

5. In the top row of the table, select Simulate 8.x.

The Simulate ONTAP 8 page is displayed.

6. In the row that corresponds to the version of Simulate ONTAP you want to use (for example,
8.2.0), select the 7-mode or clustered link to download the 7-Mode or clustered Data ONTAP
version of the simulator software. Note that there is a separate link for VMware ESX builds.

The Simulate ONTAP Software License page is displayed.

7. Read the license and click Accept at the bottom of the page.

The File Download popup window is displayed.

8. Click the Save button to save the zip file to the location as described below:
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If you are downloading to... Then...

a Windows system Save the file to the C:\Virtual Machines folder

a Mac system Save the file to the download folder

9. When the download completes, return to the Simulate ONTAP 8 page and click the VSIM
Licenses link to display the list of Data ONTAP licenses that you need in order to unlock certain
Data ONTAP features. Save this information to your computer.

You have successfully downloaded the Simulate ONTAP software and license file.

After you finish

On a Windows system, extract the zip file in the C:\Virtual Machines folder.

On a Mac system the zip file is extracted automatically.
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Installing Simulate ONTAP on a Windows system

You can install Simulate ONTAP on a Windows system and test the features of Data ONTAP 7-
Mode or clustered Data ONTAP software.

In a Windows system, you need to have one of the following VMware applications installed before
you can run Simulate ONTAP:

• VMware Workstation
• VMware Player

Windows system requirements
You must ensure that the hardware and software prerequisites are met before installing Simulate
ONTAP on a Windows system.

Hardware requirements

• Dual core 64-bit Intel or AMD system
• 2 GB RAM for one instance of simulator
• 3 GB RAM for two instances of simulator (4 GB recommended)
• 40 GB free disk space for each instance of the simulator
• VT support for Intel system

Software requirements

• Microsoft Windows XP, Windows 7, or Windows Vista
• VMware Workstation (8.0.1 or 8.0.2) or VMware Player (4.0.1 or 4.0.2)

Enabling the VT feature
To install Simulate ONTAP on a Windows system, you must enable the VT feature. The VT can be
referred to as Vanderpool Technology, Virtualization Technology, or Virtual Machine Extensions.
The VT setting can be found under a Security or CPU screen in the BIOS.

About this task

By default, VT is disabled on an Intel-based system.

Steps

1. Access the system BIOS while booting your laptop or desktop.

2. In the BIOS, enable VT if it is not already enabled.

3. Save the changes to the BIOS settings and then turn off the system.
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4. Turn on the system again.

Note: If you reboot the system without turning it off, VT is not enabled.

Installing Simulate ONTAP on VMware Workstation
You can download and install VMware Workstation on a Windows laptop or desktop, configure the
VMware Workstation for Simulate ONTAP, start Simulate ONTAP Guest OS on the VMware
Workstation, and configure the network adapters on the VMware Workstation.

Note: You cannot install multiple versions of VMware Workstation on the same host.

For information about installing VMware Workstation software, and for VMware Workstation
documentation, see the VMware Web site.

Related information

VMware Workstation software
Workstation User's Manual

Configuring VMware Workstation for Simulate ONTAP
Using the Preferences menu, you can change the default location for virtual machines. You can also
set the preferences for the virtual machines and software updates.

Steps

1. Click Start > All Programs > VMware > VMware Workstation.

2. In the VMware Workstation window, click Edit > Preferences.

By default, the Workspace tab is selected in the Preferences window.

3. Click Browse to select the default location for Simulate ONTAP virtual machines.

4. Select the Preferences for the following:

a) Default location for virtual machines and teams
b) Virtual machines
c) Software updates
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5. Click OK.

Configuring network adapters on VMware Workstation
You must configure network adapters on the VMware Workstation to support Simulate ONTAP on
your laptop or desktop.

About this task

There are two virtual network configurations that you can use on your laptop or desktop:

• Host-Only and Custom: All virtual interfaces used by Simulate ONTAP are set to host-only and
custom.

• Bridged and Custom: Virtual network interface vmnet0 is set to bridged and all other interfaces
used by Simulate ONTAP are set to either host-only or custom.
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If the virtual network interface vmnet0 is set as bridged, then you can use the physical Ethernet port
of your laptop to access all volumes created and mounted by using Data ONTAP. This works only if
the IP addresses and subnet are static in clustered Data ONTAP, or if 7-Mode operations support
DHCP.

Steps

1. Click Start > All Programs > VMware > Virtual Network Editor.

2. In the Virtual Network Editor window, select the virtual network interface as per your
requirements.

3. Click OK.

Starting Simulate ONTAP on VMware Workstation
You must start Simulate ONTAP on VMware Workstation to access the Simulate ONTAP console.

Steps

1. Click Start > All Programs > VMware > VMware Workstation.

2. In the VMware Workstation window, click File > Open.

3. In the Open window, select the Data ONTAP.vmx file and click Open.

4. Click the Power On button on the toolbar.

5. In the VMware Workstation window commands section, click the Power on this virtual
machine icon.
 

 

Result

Simulate ONTAP starts on the VMware Workstation.
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After you finish

For information about configuring Data ONTAP 7-Mode or clustered Data ONTAP, see Data
ONTAP 7-Mode and clustered Data ONTAP setup on page 26 and the Data ONTAP Software
Setup guides on the NetApp Support Site at support.netapp.com.

Installing Simulate ONTAP on VMware Player
You can download and install the VMware Player on a Windows laptop or desktop, start Simulate
ONTAP, set preferences for the Simulate ONTAP virtual machine, and configure network adapters
on the VMware Player.

For information about installing VMware Player software and VMware Player documentation, see
the VMware Web site.

Related information

VMware Player software
VMware Player Getting Started Guide

Starting Simulate ONTAP on VMware Player
You must start the Simulate ONTAP virtual machine to configure Data ONTAP in the VMware
Player console.

Steps

1. Click Start > All Programs > VMware > VMware Player.

2. In the VMware Player window, click Open.

3. In the Open Virtual Machine window, select Data ONTAP virtual machine (DataONTAP.vmx
file) and click Open.

Result

Simulate ONTAP opens in the VMware Player console.

Setting preferences for the Simulate ONTAP virtual machine
In the Simulate ONTAP virtual machine, you can set preferences to select the mode of exit and to
check the web for updates on startup.

Steps

1. In the VMware Player window, click the VMware Player and select Preferences.

2. In the Preferences window, select the mode of exit from one of the following options:

• Suspend the virtual machine
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• Power off the virtual machine
 

 

You can also select "Confirm before exiting the application" to receive a confirmation prompt
when exiting the virtual machine.

3. Click OK.

Configuring network adapters on VMware Player
You must configure network adapters on the VMware Player to support Simulate ONTAP on your
laptop or desktop.

Steps

1. In the VMware Player Simulate ONTAP console, click Devices.

2. Set the appropriate network type depending on the network adapters.

If you are using... Then set the network type as...

Network Adapter and Network Adapter 2 Host-only

Network Adapter 3 Bridged
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After you finish

For information about configuring Data ONTAP 7-Mode or clustered Data ONTAP, see Data
ONTAP 7-Mode and clustered Data ONTAP setup on page 26 and the Data ONTAP Software
Setup guides on the NetApp Support Site at support.netapp.com.
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Installing Simulate ONTAP on a Mac system

You can run Simulate ONTAP on a Mac operating system to test the features of the Data ONTAP 7-
Mode and clustered Data ONTAP.

Mac system requirements
You must ensure that the hardware and software prerequisites are met before installing Simulate
ONTAP on a Mac (Apple) operating system.

Hardware requirements

• Intel Core 2 Duo processor
• 2 GB RAM for one instance of simulator
• 3 GB RAM for two instances of simulator (4 GB recommended)
• 40 GB free disk space for each instance of the simulator
• Physical Address Extension (PAE) support

Software requirements

• Mac OS X Version 10.6.8
• VMware Fusion 4.1.1

Installing Simulate ONTAP on VMware Fusion
You can download and install VMware Fusion on a Mac (Apple) system, configure VMware Fusion
to run Simulate ONTAP, add Simulate ONTAP on VMware Fusion, start Simulate ONTAP, and
configure the network adapters on VMware Fusion.

For information about installing VMware Fusion software and VMware Fusion documentation, see
the VMware Web site.

Related information

VMware Fusion software
VMware Fusion documentation
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Configuring VMware Fusion to run Simulate ONTAP
To run Simulate ONTAP on a Mac operating system, you must configure VMware Fusion software
by setting the preferences on a Mac laptop or desktop.

Steps

1. On your Mac laptop or desktop, click Applications.

2. In the Applications window, click VMware Fusion.

3. Select VMware Fusion > Preferences.

4. In the General window, you can set one of the following preferences for the action to take when
closing the virtual machine.

• Suspend the virtual machine
• Power off the virtual machine

You can also select "Confirm before closing" to receive a confirmation message when closing the
virtual machine.

Adding Simulate ONTAP on VMware Fusion
To install Simulate ONTAP on VMware Fusion, you must add Simulate ONTAP to the virtual
machine library by using the VMware Fusion software.

Steps

1. On the desktop, click Applications.

2. In the Applications window, click VMware Fusion.

3. Click File > Open.

4. Select the folder where you have downloaded the Simulate ONTAP software.

5. Select the DataONTAP.vmx file to add Simulate ONTAP to your Virtual Machine Library.
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6. Repeat steps 4 and 5 to add another Data ONTAP simulator, if required.

Result

The added Simulate ONTAP virtual machines appear in the Virtual Machine Library.
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Configuring network adapters on VMware Fusion
You must configure network adapters on VMware Fusion to support Simulate ONTAP on your
computer.

You can configure the network adapters on VMware Fusion to the following types of network
configuration:

• Host-Only network adapters
• Bridged network adapters

Configuring host-only network adapters on VMware Fusion

You can configure network adapters on VMware Fusion to change to the host-only network
configuration.

Steps

1. Select a Simulate ONTAP virtual machine from the Virtual Machine Library.

2. Click VMware Fusion > Virtual Machine > Network Adapter 3 > Host-only.

Note: By default, the Network Adapter 3 is set to Bridged.

3. Click Virtual Machine > Settings.

4. Select Network.

Note: Host-Only Network configurations can use any IP subnet class. In the configuration
tested, for clustered Data ONTAP, 172.16.0.0 subnet 255.255.0.0 is used for cluster data and
10.97.105.0 subnet 255.255.255.0 is used for management and data. For Data ONTAP 7-Mode,
10.97.105.0 subnet 255.255.255.0 is used for data or management.

Result

The virtual network dialog box appears with the summary of active network adapters.
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Configuring bridged network adapters on VMware Fusion

You can configure the network adapters on VMware Fusion to the bridged network configuration.
When configured using bridged mode, you can export volumes and manage simulator guests by
using static IP address.

Steps

1. Select a Simulate ONTAP virtual machine from the Virtual Machine Library.

2. Click VMware Fusion > Virtual Machine > Network Adapter 3 > Bridged.

Note: By default, the Network Adapter 3 is set to Bridged.

3. Click Virtual Machine > Settings.

4. Select Network.

Note:

Changes are automatically saved when you close the virtual network editor dialog box.

Result

The virtual network dialog box appears with the summary of active bridged network adapters.

After you finish

Consult with your local IT support group for static IP address allocation for Data ONTAP 7-Mode
and clustered Data ONTAP simulators.
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Starting Simulate ONTAP on VMware Fusion
You must start the Simulate ONTAP virtual machine to configure Data ONTAP in the VMware
Fusion console.

Steps

1. On the desktop, click Applications.

2. In the Applications window, click VMware Fusion.

3. Click Window > Virtual Machine Library.

4. Select a Simulate ONTAP virtual machine from the Virtual Machine Library.

5. Click Start up guest.

Result

Simulate ONTAP starts in a VMware Fusion console.

After you finish

For information about configuring Data ONTAP 7-Mode or clustered Data ONTAP, see Data
ONTAP 7-Mode and clustered Data ONTAP setup on page 26 and the Data ONTAP Software
Setup guides on the NetApp Support Site at support.netapp.com.
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Installing Simulate ONTAP on VMware vSphere

You can install Simulate ONTAP on a VMware vSphere system and test the features of Data
ONTAP 7-Mode or clustered Data ONTAP software.

VMware vSphere system requirements
You must ensure that the hardware and software prerequisites are met before installing Simulate
ONTAP on a VMware ESX system.

Software requirements

The virtualization platform software requirements include:

• VMware vSphere 4.1 update 1 including VMware ESX and VMware vSphere Client, and
optionally vCenter Server

Hardware requirements

The minimum hardware requirements for the ESX server are listed as follows:

• Dual core 64-bit Intel or AMD system
• 2-GB RAM for one instance of simulator
• 3-GB RAM for two instances of simulator (4 GB recommended)
• 40-GB free disk space for each instance of the simulator
• VT support for Intel system

There are additional networking requirements when installing Simulate ONTAP on an ESX host.
There are also requirements for the computer on which the vSphere Client software is installed. For
more information, see the "System Requirements" chapter of the VMware ESX and vCenter Server
Installation Guide for complete hardware and software requirements.

Installing Simulate ONTAP on VMware ESX
You can download and install VMware ESX on a server, and then install and start Simulate ONTAP
on that server.

VMware ESX is different than the other VMware virtualization software described in this manual
because it cannot be installed on a laptop—it must be installed on a server. Additionally, you must
install the VMware vSphere Client on a separate computer to install and manage the Simulate
ONTAP virtual machine on the ESX host. For this reason it is recommended that you install Simulate
ONTAP on ESX only if you are familiar with VMware ESX, or if someone at your site has this
knowledge.
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For information about installing VMware ESX and VMware vSphere Client software, and for
VMware ESX documentation, see the VMware Web site.

The following tasks are described in this section:

• Create a cluster network (required only when using clustered Data ONTAP)
• Copy the Simulate ONTAP files to a local or NAS datastore
• Create a NAS network (required only when accessing Simulate ONTAP on a NAS datastore)
• Register the Simulate ONTAP virtual machine
• Start the Simulate ONTAP virtual machine

Related information

VMware ESX 4.1 software
Getting Started with ESX
ESX and vCenter Server Installation Guide

Creating a cluster network
When running clustered Data ONTAP, you must create a network for the cluster traffic that is
separate from the network for data traffic. This effectively creates a virtual machine port group.

About this task

Note that both Simulate ONTAP instances in the cluster must be running on the same ESX server.

If you are running Data ONTAP in 7-Mode, skip this section.

Steps

1. Log in to the vSphere Client and select the ESX host from the inventory panel.

2. Select the Configuration tab and click Networking (under the Hardware list).

3. In the Virtual Switch view, click Add Networking.

The Add Network Wizard is launched.

4. In the Connection Type page, select Virtual Machine and click Next.

5. In the Virtual Machines - Network Access page, perform the following steps:

a) Select the vSwitch to use, or select Create a virtual switch to create a new vSwitch.
b) Do not select a check box to identify a virtual network adapter. Not selecting a virtual NIC

makes the network internal to the ESX host.
c) Click Next.

6. In the Virtual Machines - Connection Settings page, perform the following steps:

a) In the "Network Label" field, enter a name that identifies the network you are creating, for
example, "Cluster Network".

b) Click Next.
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7. In the Ready to Complete page, verify the details about the Virtual Machine port group you are
adding and click Finish. Note that you can click Back if you need to make any corrections.

Result

The cluster network is created successfully.

Adding Simulate ONTAP on VMware ESX
The Simulate ONTAP files can reside on a local datastore or a remote datastore.

Before you begin

Make sure you have downloaded the correct Simulate ONTAP zip file that has been made for
VMware ESX servers.

About this task

Follow one of the steps below:

Choices

• If the Simulate ONTAP files are going to be accessed from the local datastore, copy the files to
the local datastore, for example, /vmfs/volume/datastore1.

• If the Simulate ONTAP files are going to be accessed through a NAS datastore, copy the files to
the remote datastore.

Result

The Simulate ONTAP files reside on the datastore you want to use.

Creating a network to access the NAS datastore
If you are planning to access the Simulate ONTAP files through a NAS datastore, then you need to
create a network on the ESX server that will enable communication with the remote datastore. This
step creates a VMkernel port group (network) where the NAS can be mounted on the ESX server.

About this task

See the VMware ESX Configuration Guide if you need more details about creating a new network.

If you are accessing Simulate ONTAP files on a local datastore, skip this section.

Steps

1. Log in to the vSphere Client and select the ESX host from the inventory panel.

2. Select the Configuration tab and click Networking (under the Hardware list).

3. In the Virtual Switch view, click Add Networking.
The Add Network Wizard is launched.
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4. In the Connection Type page, select VMkernel and click Next.

5. In the VMkernel - Network Access page, perform the following steps:

a) Select the vSwitch to use, or select Create a virtual switch to create a new vSwitch.
b) Select the check box(es) for the virtual network adapter(s) your vSwitch will use to provide

access to the datastore.
c) Click Next.

6. In the VMkernel - Connection Settings page, perform the following steps:

a) In the "Network Label" field, enter a name that identifies the network you are creating, for
example, "Datastore Network".

b) Click Next.

7. In the VMkernel - IP Connection Settings page, perform the following steps:

a) Enter the IP connection details manually, or select Obtain IP settings automatically to use
DHCP to obtain the IP settings.

b) Click Next.

8. In the Ready to Complete page, verify the details about the VMkernel port group you are adding
and click Finish. Note that you can click Back if you need to make any corrections.

If you receive a message about the gateway not being specified, enter the Default gateway details
and click Finish.

9. Mount the datastore as a NAS datastore on the ESX server.

Result

The VMkernel network that will be used to access the NAS datastore is created successfully and the
datastore is mounted.

Registering Simulate ONTAP on an ESX server
To register Simulate ONTAP on an ESX server, you must identify the Simulate ONTAP
configuration file (.vmx file) from the files you previously copied to either the local or the NAS
datastore.

Steps

1. Log in to the vSphere Client and select the ESX host from the inventory panel.

2. Select the Configuration tab and click Storage (under the Hardware list).

3. Right-click on the datastore in which the Simulate ONTAP files are located and select Browse
Datastore. This can be the local datastore or a NAS datastore.

The Datastore Browser window displays.

4. In the Datastore Browser, open the directory in which the Simulate ONTAP files reside and select
the DataONTAP.vmx file.
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5. Right-click the .vmx file and select Add to Inventory.

6. In the Name page, enter a name for the Simulate ONTAP virtual machine (for example,
"DataONTAP_sim") and click Next.

7. In the Resource Pool page, select the resource pool in which the virtual machine will run, and
click Next. Note that the resource pool must allocate at least 4 GB RAM and 2 CPUs per
simulator, and it must already exist.

8. In the Ready to Complete page, verify the details about the virtual machine you are adding to
inventory and click Finish. Note that you can click Back if you need to make any corrections.

Result

The Simulate ONTAP virtual machine is registered with the ESX server.

Starting Simulate ONTAP on VMware ESX
You must start the Simulate ONTAP virtual machine to access Data ONTAP through the VMware
ESX console.

Steps

1. In the left pane of the vSphere Client, select the Simulate ONTAP virtual machine that you
created (for example, "DataONTAP_sim").

2. Click the Summary tab to view the details about this virtual machine.

3. Click the Power On button to start the virtual machine.

4. After the virtual machine is running, open the console to the Data ONTAP interface by
performing one of these tasks:

• Right-click the virtual machine and select Open Console to open the console in a separate
window.

• Click the Console tab to open the console within the vSphere Client window.

Note that you must press Ctrl-Alt to free the cursor from the console window to perform other
tasks.

Result

Simulate ONTAP is running and the console is available for managing the Data ONTAP system.

After you finish

For information about configuring Data ONTAP 7-Mode or clustered Data ONTAP, see Data
ONTAP 7-Mode and clustered Data ONTAP setup on page 26 and the Data ONTAP Software
Setup guides on the NetApp Support Site at support.netapp.com.
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Data ONTAP 7-Mode and clustered Data ONTAP
setup

You can setup either Data ONTAP 7-Mode software or clustered Data ONTAP software on Simulate
ONTAP virtual machines to test Data ONTAP features.

You will need to collect information about the network, such as IP addresses, network mask, default
gateway, and so on, before setting up the Simulate ONTAP virtual machine.

For complete information about configuring Data ONTAP 7-Mode or clustered Data ONTAP, see
the Data ONTAP Software Setup guides on the NetApp Support Site at support.netapp.com.

Configuring your clustered Data ONTAP simulators
Configuring a cluster of Data ONTAP simulators involves setting up clustered Data ONTAP
software on one or more simulators. You create the cluster while setting up the first node, and then
you join the second node to the cluster while setting up the second node.

You must initialize the simulator to run it for the first time.

Note: The simulator might hang and reboot repeatedly if the initialization steps are not performed
correctly.

Booting the first node
You should use the Cluster Setup wizard to create the cluster on the first node. The wizard helps you
to configure the cluster network that connects the nodes, create the cluster admin Vserver, add
feature license keys, and create the node management interface for the first node. You must boot the
first node to create the cluster.

Steps

1. Click inside the vSphere Client Console window for the simulator virtual machine, and when the
Press Ctrl-C for Boot Menu message is displayed, press Ctrl-C.

NetApp Data ONTAP 8.x.x Cluster-Mode 
Copyright (C) 1992-2013 NetApp.
All rights reserved.
running fsck_msdosfs on /cfcard
md1.uzip: 39168 x 16384 blocks
md2.uzip: 5760 x 16384 blocks
*******************************
*                             *
* Press Ctrl-C for Boot Menu. *
*                             *
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*******************************
^CBoot Menu will be available.

Note: You might see disk messages before the menu appears; ignore such messages at this
time.

2. When the Boot Menu is displayed, enter 4 and press Enter.

Please choose one of the following:

(1) Normal Boot.
(2) Boot without /etc/rc.
(3) Change password.
(4) Clean configuration and initialize all disks.
(5) Maintenance mode boot.
(6) Update flash from backup config.
(7) Install new software first.
(8) Reboot node.
Selection (1-8)? 4

3. At the Zero disk, reset config and install a new file system? prompt, enter y
and press Enter.

Zero disks, reset config and install a new file system?: y

4. At the confirmation prompt, enter y and press Enter.

The VM restarts automatically and begins the reset process.

This will erase all the data on the disks, are you sure?: y
Rebooting to finish wipeconfig request.
Skipped backing up /var file system to CF.

Note: You must wait until the reset process is completely finished. If you stop the process, you
might corrupt the simulator files (simulator disks) and might be required to extract them again.
After the VM resets, the cluster setup wizard will start.

Creating the cluster
Creating a cluster enables you to pool the resources and distribute work across the members (nodes)
of the cluster, while presenting administrators with a single entity to manage. Clustering also enables
continuous service to end users if individual nodes go offline or are taken offline.

Before you begin

You should have obtained a base cluster license and Data ONTAP features licenses from the
Simulate ONTAP download page.
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Steps

1. Create a cluster by entering create and then press Enter.

Welcome to the cluster setup wizard.

You can enter the following commands at any time:
  "help" or "?" - if you want to have a question clarified,
  "back" - if you want to change previously answered questions, and
  "exit" or "quit" - if you want to quit the cluster setup wizard.
     Any changes you made before quitting will be saved.

You can return to cluster setup at any time by typing "cluster setup".
To accept a default or omit a question, do not enter a value.

Do you want to create a new cluster or join an existing cluster? 
{create}:
create

2. When asked to use the system default values, press Enter to accept the default answer yes. The
default answer, when available, is shown in brackets.

System Defaults:
Private cluster network ports [e0a].
Cluster port MTU values will be set to 1500.
Cluster interface IP addresses will be automatically generated.

Do you want to use these defaults? {yes, no} [yes]: <Enter>

3. After the cluster interfaces are created, enter a name for your cluster.

It can take several minutes to create cluster interfaces...
Step 1 of 5: Create a Cluster
You can type "back", "exit", or "help" at any question.

Enter the cluster name: cluster1

4. When prompted for the cluster base license key, enter the base license you downloaded.

Enter the cluster base license key: ETYYFLXUQUMADFAAAAAAAAAAAAAA

5. When prompted to enter feature licenses, press Enter to continue.

Data ONTAP feature licenses can be added at a later time when needed.

6. When prompted for an "admin" password, enter a strong password with numbers and letters and
confirm. Write your password down in the space below and DO NOT LOSE IT.

Password: _________________________

7. Press Ctrl+Alt to exit the Console window and return to the Windows operating system. Open a
Windows command prompt and enter ipconfig.
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The following steps require knowledge of VMware addresses that were created during the virtual
machine install.

Ethernet adapter VMware Network Adapter VMnet8:
Connection-specific DNS Suffix.:
Link-local IPv6 Address........: fe80::e95e:d77a:1b5b:a70dz22
IPv4 Address...................: 192.168.x.20
Subnet Mask....................: 255.255.255.0
Default Gateway................:

You must find the VMnet8 (NAT) IP Address. You must assign IP addresses to the simulator
ports in the VMnet8 subnet (for example 192.168.65.20). Note the IPv4 Address and subnet
mask.

VMnet8 IPv4 Address: __________________________________________

VMnet8 Subnet Mask: __________________________________________

Note: The preceding example is specific to VMware Player environment. You should
configure IPs for e0c and e0d ports based on your network settings.

8. Return to the vSphere Console window for the simulator and enter the following values to define
the cluster management port using the information you gathered in the previous step:

• Enter the cluster management interface port [e0c]: e0c
• Enter the cluster management interface IP address: 192.168.x.20. ( x =your subnet)
• Enter the cluster management interface netmask: 255.255.255.0
• Enter the cluster management interface default gateway: (leave blank)

Enter the cluster management interface port [e0c]: e0c    
Enter the cluster management interface IP address: 192.168.x.20  
Enter the cluster management interface netmask: 255.255.255.0    
Enter the cluster management interface default gateway: <Enter>

A cluster management interface on port e0c with IP address 192.168.x.
20 has been created. 
You can use this address to connect to and manager the cluster.

Enter the DNS domain names: <Enter>

You connect to and manage the cluster using the cluster management interface IP address. Enter
that IP address in the space provided below:

Cluster Management Interface: __________________________________________

Note: The preceding example is specific to the VMware Player environment. You should
configure IPs for e0c and e0d ports based on your network settings.

9. Press Enter when prompted for the DNS domain names to continue to the next step.
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10. The setup wizard continues with Storage Failover (SFO) information. When asked for a location
of the controller, enter the type of location; for example, the name of the building or the lab, and
press Enter to continue.

Where is the controller located []: lab2

11. Enter the following values to define the node management port using the information you
gathered in the previous steps:

• Enter the node management interface port [e0c]: e0c
• Enter the node management interface IP address: 192.168.x.21 ( x is your subnet)
• Enter the node management interface netmask: 255.255.255.0
• Enter the node management interface default gateway: <Enter>

Enter the node management interface port [e0c]: <Enter>
Enter the node management interface IP address: 192.168.x.21
Enter the node management interface netmask: 255.255.255.0
Enter the node management interface default gateway: <Enter>
A node management interface on port e0c with IP address 192.168.x.21 
has been created.

Note: The preceding example is specific to the VMware Player environment. You should
configure IPs for e0c and e0d ports based on your network settings.

12. The setup wizard continues to create the node management interface. Press Enter to continue.

Cluster setup is now complete. 
To begin storing and serving data on this cluster, you must complete 
the following additional tasks if they have not already been 
completed:

1) Join additional nodes to the cluster by running "cluster setup" on
   those nodes.
2) If in a HA configuration, verify that storage failover is enabled
   by running the "storage failover show" command.
3) Create a Vserver by running the "vserver setup" command.

Cluster setup is now complete.

You can access your cluster to complete these tasks by:

1) Using the NetApp System Manager to manage cluster cluster1 at
   192.168.x.20.
   NetApp System Manager must be at version 2.0 or above.
   You can download System Manager from http://support.netapp.com

2) Logging in to the cluster by using SSH (secure shell) from your
   work station:
   ssh admin@192.168.x.20
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Exiting the cluster setup wizard

13. To test the cluster, log in and enter the cluster show command.

login: admin
Password: <password you defined>

cluster1::> cluster show
Node                  Health  Eligibility
--------------------- ------- ------------
cluster1-01     true    true
1 entry is displayed.

14. Add the unassigned disks to the node by entering the following command:

> storage disk assign –all true –node cluster1-01

Note: The simulator should not be shut down at this time. The console window can be
minimized while you set up the second node in the cluster (if required).

Configuring serial number and system ID for the second node
You must perform an additional step on the second node because the storage system ID is hardcoded
in the provided Simulate ONTAP image. Each Simulate ONTAP node in a cluster must have a
unique System ID.

Steps

1. Download and extract a second set of simulator files for the second node as described in 
Downloading Simulate ONTAP software on page 6.

2. Navigate to C:\Virtual Machines\vsim-DOTxxx-cm and rename the new folder as vsim-
cm-N2 to identify it as the second node.

3. Register the virtual machine.

4. Edit node two Virtual Machine Settings.

5. Under the Hardware tab, select the Serial Port device and rename the Use named pipe to

\\.\pipe\vsim-cm-N2-cons

(vsim-cm-N2 is the name of the simulator folder).

6. Under the Hardware tab, select the Serial Port 2 device and rename the Use named pipe to

\\.\pipe\vsim-cm-N2-gdb

.

7. Rename the Virtual Machine to vsim-cm-node2

8. Change the System ID and serial number of the second node before joining the cluster.
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9. Press the space bar when the Hit [Enter] to boot immediately, or any other key
for command prompt. Booting in 10 seconds... message is displayed.

You should see a VLOADER> prompt.

10. Change the Serial Number and System ID for this node:

VLOADER> setenv SYS_SERIAL_NUM 4034389-06-2

VLOADER> setenv bootarg.nvram.sysid 4034389062

11. Verify that the information was saved correctly by entering the following two commands:

VLOADER> printenv SYS_SERIAL_NUM

VLOADER> printenv bootarg.nvram.sysid

12. Enter the boot command to boot the node: VLOADER> boot

The simulator begins the boot process with the new system id and serial number.

Booting the second node
You must reboot the node to configure it and to connect it to the cluster.

Steps

1. When the Press Ctrl-C for Boot Menu message is displayed, press Ctrl-C to display the
Boot Menu.

NetApp Data ONTAP 8.x.x Cluster-Mode
Copyright (C) 1992-2013 NetApp.
All rights reserved.
*******************************
*                             *
* Press Ctrl-C for Boot Menu. *
*                             *
*******************************
^C 
Boot Menu will be available.

2. When the Boot Menu is displayed, enter 4 (to initialize all disks) and press Enter.

Please choose one of the following:

(1) Normal Boot.
(2) Boot without /etc/rc.
(3) Change password.
(4) Clean configuration and initialize all disks.
(5) Maintenance mode boot.
(6) Update flash from backup config.
(7) Install new software first.
(8) Reboot node.
Selection (1-8)? 4
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3. Enter y and press Enter at the Zero disk, reset config and install a new file
system? prompt.

Zero disks, reset config and install a new file system?: y

4. At the confirmation prompt, enter y and press Enter.

This will erase all the data on the disks, are you sure?: y
Rebooting to finish wipeconfig request.

Result

The virtual machine restarts automatically and begins the reset process. You must wait until the reset
process is complete. If you interrupt the process, you might corrupt the simulator files (simulator
disks) and you might have to extract them again.

Joining the node to the cluster
After creating a cluster, for each remaining node, you use the Cluster Setup wizard to join the node to
the cluster and create the node's management interface.

About this task

After the reset process is complete, the cluster setup wizard will start.

Steps

1. Join the cluster you created earlier by entering the join command and pressing Enter.

The cluster setup wizard is displayed.

Welcome to the cluster setup wizard.

You can enter the following commands at any time:
  "help" or "?" - if you want to have a question clarified,
  "back" - if you want to change previously answered questions, and
  "exit" or "quit" - if you want to quit the cluster setup wizard.
     Any changes you made before quitting will be saved.

You can return to cluster setup at any time by typing "cluster setup".
To accept a default or omit a question, do not enter a value.

Do you want to create a new cluster or join an existing cluster? 
{join}:
join

2. When asked to use the system default values, press Enter to accept the default answer, which is

yes
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System Defaults:
Private cluster network ports [e0a].
Cluster port MTU values will be set to 1500.
Cluster interface IP addresses will be automatically generated.

Do you want to use these defaults? {yes, no} [yes]: <Enter>

3. After the cluster interfaces are created, enter the name of the cluster you want to join. Press Enter
to join "cluster1".

It can take several minutes to create cluster interfaces...
Step 1 of 3: Join an Existing Cluster
You can type "back", "exit", or "help" at any question.

Enter the name of the cluster you would like to join [cluster1]: 
<Enter>

Wait while node 2 joins the cluster.

4. Enter the following values to define the node interface using the information you gathered when
setting up the first node:

You must ensure that you enter a unique IP for node management interface (22, as shown below).

• Enter the node management interface port [e0c]: e0c
• Enter the node management interface IP address: 192.168.x.22 (x=your subnet)
• Enter the node management interface netmask: 255.255.255.0
• Enter the node management default gateway: (leave blank)

Step 3 of 3: Set Up the Node
You can type "back", "exit", or "help" at any question.

Enter the node management interface port [e0c]: <Enter>
Enter the node management interface IP address: 192.168.x.22
Enter the node management interface netmask [255.255.255.0]: <Enter>
Enter the node management interface default gateway: <Enter>

Note: You should configure IPs for e0c and e0d ports based on your network settings.

5. The setup wizard will continue to create the node management interface. Press Enter to continue.

The cluster setup is now complete.

A node management interface on port e0c with IP address 192.168.x.22 
has been created.

Cluster setup is now complete. 
To begin storing and serving data on this cluster, you must complete 
the following additional tasks if they have not already been 
completed:

1) Join additional nodes to the cluster by running "cluster setup" on
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   those nodes.
2) If in a HA configuration, verify that storage failover is enabled 
by running the "storage failover show" command.
3) Create a Vserver by running the "vserver setup" command.

You can access your cluster to complete these tasks by:

1) Using the NetApp System Manager to manage cluster cluster1 at
   192.168.x.22.
   NetApp System Manager must be at version 2.0 or above.
   You can download System Manager from http://support.netapp.com

2) Logging in to the cluster by using SSH (secure shell) from your
   work station:
   ssh admin@192.168.x.20

6. To test the cluster, log in and enter the cluster show command.

There will now be two nodes in the cluster.

login: admin
Password: <password you defined>

cluster1::> cluster show
Node                  Health  Eligibility
--------------------- ------- ------------
cluster1-01     true    true
cluster1-02     true    true
2 entries were displayed.

7. To assign ownership of unowned disks to a specific node, enter the following command:

> storage disk assign –all true –node cluster1-02.

You have completed a two-node cluster setup. The console window can be minimized, but the
simulator should not be shut down at this time.
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How to send your comments

You can help us to improve the quality of our documentation by sending us your feedback.

Your feedback is important in helping us to provide the most accurate and high-quality information.
If you have suggestions for improving this document, send us your comments by email to 
doccomments@netapp.com. To help us direct your comments to the correct division, include in the
subject line the product name, version, and operating system.

You can also contact us in the following ways:

• NetApp, Inc., 495 East Java Drive, Sunnyvale, CA 94089 U.S.
• Telephone: +1 (408) 822-6000
• Fax: +1 (408) 822-4501
• Support telephone: +1 (888) 463-8277
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